Email processing delays
Incident Report for Safecall
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 14:03 GMT
Investigating
We are currently experiencing sporadic processing delays when sending emails. This may impact your ability to log in to the system, as the 2FA code may have expired when the email arrives. If this occurs, please attempt a fresh log in.

All emails will eventually arrive, and no data will be lost.

We apologise for any inconvenience this may cause.
Posted Nov 24, 2020 - 11:42 GMT
This incident affected: Case Management Platform (Report management system).